CVERadar
HIGH · CVSS 3.1 7.8Public PoCEPSS 0.19% (p9)Threat level 43

CVE-2026-43494: CVE-2026-43494: In the Linux kernel, the following vulnerability has been resolved: net/rds: reset op_nen…

linux · linux kernel · NVD published 2026-05-21 · posted 2026-05-21 · last modified 2026-10-20

What it is

In the Linux kernel, the following vulnerability has been resolved: net/rds: reset op_nents when zerocopy page pin fails When iov_iter_get_pages2() fails in rds_message_zcopy_from_user(), the pinned pages are released with put_page(), and rm->data.op_mmp_znotifier is cleared. But we fail to properly clear rm->data.op_nents. Later when rds_message_purge() is called from rds_sendmsg() the cleanup loop iterates over the incorrectly non zero number of op_nents and frees them again. Fix this by properly resetting op_nents when it should be in rds_message_zcopy_from_user().

WeaknessCWE-415CWE-1341
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H (source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67)
ATT&CK tacticsn/a

Exploitation evidence

First exploit evidence seen: 2026-05-21 (earliest date across the sources below).

Exploited in the wild

No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).

Public exploit code

GitHub proof-of-concept repositories

7 public repositories from 7 accounts, first seen 2026-05-21. Most starred: 0xBlackash/CVE-2026-43494 (2 stars), view repository.

Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.

Sources: nomi-sec/PoC-in-GitHub.

How to fix it

Fixed versions

  • linux linux kernel: upgrade to 5.10.258 or later (affected from 4.17)
  • linux linux kernel: upgrade to 5.15.209 or later (affected from 5.11)
  • linux linux kernel: upgrade to 6.1.175 or later (affected from 5.16)
  • linux linux kernel: upgrade to 6.6.141 or later (affected from 6.2)
  • linux linux kernel: upgrade to 6.12.91 or later (affected from 6.7)
  • linux linux kernel: upgrade to 6.18.33 or later (affected from 6.13)
  • linux linux kernel: upgrade to 7.0.10 or later (affected from 6.19)

Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.

Vendor advisories and patches

Detection Generic guidance

    Response checklist Generic guidance

    1. Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
    2. Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
    3. Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
    4. Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.

    Sources