HIGH · CVSS 4.0 7.2Exploit-DBEPSS 73.30% (p99)Threat level 65
CVE-2025-6965: CVE-2025-6965: There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregat…
sqlite · sqlite · NVD published 2025-07-15 · posted 2026-04-08 · last modified 2026-10-15
What it is
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.
| Weakness | CWE-197 |
|---|---|
| CVSS vector | CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:N/R:U/V:D/RE:L/U:Green (source: [email protected]) |
| ATT&CK tactics | n/a |
Exploitation evidence
First exploit evidence seen: 2026-04-08 (earliest date across the sources below).
Exploited in the wild
No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).
Public exploit code
Exploit-DB
- EDB-52499: SQLite 3.50.1 - Heap Overflow (2026-04-08)
Sources: Exploit-DB (OffSec).
No ATT&CK techniques could be mapped or inferred for this CVE yet.
How to fix it
Fixed versions
- sqlite sqlite: upgrade to 3.50.2 or later
- apple ipados: upgrade to 26.0.0 or later
- apple iphone os: upgrade to 26.0.0 or later
- apple macos: upgrade to 26.0.0 or later
- apple tvos: upgrade to 26.0.0 or later
- apple visionos: upgrade to 26.0.0 or later
- apple watchos: upgrade to 26.0.0 or later
- siemens ruggedcom crossbow: upgrade to 5.8 or later
- siemens sidis prime: upgrade to 4.0.800 or later
Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.
Vendor advisories and patches
- https://www.sqlite.org/src/info/5508b56fd24016c13981ec280ecdd833007c9d8dd595edb295b984c2b487b5c8 (Patch)
Detection Generic guidance
Response checklist Generic guidance
- Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
- Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
- Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
- Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.
Sources
- NVD: CVE-2025-6965
- CVE.org record
- FIRST EPSS (2026-10-24)
- http://seclists.org/fulldisclosure/2025/Sep/49 (Third Party Advisory)
- http://seclists.org/fulldisclosure/2025/Sep/53 (Third Party Advisory)
- http://seclists.org/fulldisclosure/2025/Sep/56 (Third Party Advisory)
- http://seclists.org/fulldisclosure/2025/Sep/57 (Third Party Advisory)
- http://seclists.org/fulldisclosure/2025/Sep/58 (Third Party Advisory)
- http://www.openwall.com/lists/oss-security/2025/09/06/1 (Third Party Advisory)
- https://cert-portal.siemens.com/productcert/html/ssa-225816.html (Third Party Advisory)
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html (Third Party Advisory)
- https://cert-portal.siemens.com/productcert/html/ssa-765416.html