CVERadar
MEDIUM · CVSS 3.1 5.3Public PoCEPSS 64.23% (p99)Threat level 50

CVE-2025-55183: CVE-2025-55183: An information leak vulnerability exists in specific configurations of React Server Compon…

vercel · next.js · NVD published 2025-12-12 · posted 2025-12-11 · last modified 2026-10-08

What it is

An information leak vulnerability exists in specific configurations of React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1, including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. A specifically crafted HTTP request sent to a vulnerable Server Function may unsafely return the source code of any Server Function. Exploitation requires the existence of a Server Function which explicitly or implicitly exposes a stringified argument.

WeaknessNot specified
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N (source: [email protected])
ATT&CK tacticsn/a

Exploitation evidence

First exploit evidence seen: 2025-12-11 (earliest date across the sources below).

Exploited in the wild

No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).

Public exploit code

GitHub proof-of-concept repositories

6 public repositories from 6 accounts, first seen 2025-12-11. Most starred: williavs/nextjs-security-update (8 stars), view repository.

Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.

Sources: nomi-sec/PoC-in-GitHub.

How to fix it

Fixed versions

  • vercel next.js: upgrade to 15.0.7 or later (affected from 15.0.0)
  • vercel next.js: upgrade to 15.1.11 or later (affected from 15.1.0)
  • vercel next.js: upgrade to 15.2.8 or later (affected from 15.2.0)
  • vercel next.js: upgrade to 15.3.8 or later (affected from 15.3.0)
  • vercel next.js: upgrade to 15.4.10 or later (affected from 15.4.0)
  • vercel next.js: upgrade to 15.5.9 or later (affected from 15.5.0)
  • vercel next.js: upgrade to 16.0.10 or later (affected from 16.0.0)
  • facebook react: upgrade to 19.0.2 or later (affected from 19.0.0)
  • facebook react: upgrade to 19.1.3 or later (affected from 19.1.0)
  • facebook react: upgrade to 19.2.2 or later (affected from 19.2.0)

Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.

Vendor advisories and patches

Detection Generic guidance

    Response checklist Generic guidance

    1. Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
    2. Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
    3. Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
    4. Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.

    Sources