CVE-2025-39964: Linux Kernel Race Condition Vulnerability
Linux · Kernel · NVD published 2025-10-13 · posted 2026-09-18 · last modified 2026-10-20
What it is
In the Linux kernel, the following vulnerability has been resolved: crypto: af_alg - Disallow concurrent writes in af_alg_sendmsg Issuing two writes to the same af_alg socket is bogus as the data will be interleaved in an unpredictable fashion. Furthermore, concurrent writes may create inconsistencies in the internal socket state. Disallow this by adding a new ctx->write field that indiciates exclusive ownership for writing.
| Weakness | CWE-362 |
|---|---|
| CVSS vector | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H (source: [email protected]) |
| CISA due date | 2026-09-21 (for US federal agencies under BOD; a good deadline for everyone) |
| ATT&CK tactics | n/a |
Exploitation evidence
First exploit evidence seen: 2026-09-18 (earliest date across the sources below).
Exploited in the wild
- CISA KEV: listed since 2026-09-18. Source
Public exploit code
GitHub proof-of-concept repositories below quality bar
2 public repositories from 2 accounts, first seen 2025-11-13.
Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.
Sources: CISA KEV · nomi-sec/PoC-in-GitHub.
No ATT&CK techniques could be mapped or inferred for this CVE yet.
How to fix it
CISA required action
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines. (source: CISA KEV)
Fixed versions
- linux linux kernel: upgrade to 5.10.245 or later (affected from 2.6.38)
- linux linux kernel: upgrade to 5.15.194 or later (affected from 5.11)
- linux linux kernel: upgrade to 6.1.154 or later (affected from 5.16)
- linux linux kernel: upgrade to 6.6.108 or later (affected from 6.2)
- linux linux kernel: upgrade to 6.12.49 or later (affected from 6.7)
- linux linux kernel: upgrade to 6.16.9 or later (affected from 6.13)
Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.
Vendor advisories and patches
- https://git.kernel.org/stable/c/0f28c4adbc4a97437874c9b669fd7958a8c6d6ce (CISA KEV notes)
- https://git.kernel.org/stable/c/e4c1ec11132ec466f7362a95f36a506ce4dc08c9 (CISA KEV notes)
- https://git.kernel.org/stable/c/1f323a48e9b5ebfe6dc7d130fdf5c3c0e92a07c8 (CISA KEV notes)
- https://git.kernel.org/stable/c/7c4491b5644e3a3708f3dbd7591be0a570135b84 (CISA KEV notes)
- https://git.kernel.org/stable/c/9aee87da5572b3a14075f501752e209801160d3d (CISA KEV notes)
- https://git.kernel.org/stable/c/45bcf60fe49b37daab1acee57b27211ad1574042 (CISA KEV notes)
- https://git.kernel.org/stable/c/1b34cbbf4f011a121ef7b2d7d6e6920a036d5285 (CISA KEV notes)
Detection Generic guidance
Response checklist Generic guidance
- Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
- Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
- Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
- Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.
Sources
- NVD: CVE-2025-39964
- CVE.org record
- CISA Known Exploited Vulnerabilities catalog
- FIRST EPSS (2026-10-24)
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html (Third Party Advisory)
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html (Third Party Advisory)
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-39964 (US Government Resource)