CVERadar
MEDIUM · CVSS 3.1 5.5Public PoCEPSS 10.26% (p96)Threat level 35

CVE-2025-39946: CVE-2025-39946: In the Linux kernel, the following vulnerability has been resolved: tls: make sure to abo…

linux · linux kernel · NVD published 2025-10-04 · posted 2025-10-04 · last modified 2026-10-20

What it is

In the Linux kernel, the following vulnerability has been resolved: tls: make sure to abort the stream if headers are bogus Normally we wait for the socket to buffer up the whole record before we service it. If the socket has a tiny buffer, however, we read out the data sooner, to prevent connection stalls. Make sure that we abort the connection when we find out late that the record is actually invalid. Retrying the parsing is fine in itself but since we copy some more data each time before we parse we can overflow the allocated skb space. Constructing a scenario in which we're under pressure without enough data in the socket to parse the length upfront is quite hard. syzbot figured out a way to do this by serving us the header in small OOB sends, and then filling in the recvbuf with a large normal send. Make sure that tls_rx_msg_size() aborts strp, if we reach an invalid record there's really no way to recover.

WeaknessNot specified
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H (source: [email protected])
ATT&CK tacticsn/a

Exploitation evidence

First exploit evidence seen: 2025-10-04 (earliest date across the sources below).

Exploited in the wild

No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).

Public exploit code

GitHub proof-of-concept repositories

1 public repositories from 1 accounts, first seen 2025-10-04. Most starred: farazsth98/exploit-CVE-2025-39946 (37 stars), view repository.

Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.

Sources: nomi-sec/PoC-in-GitHub.

How to fix it

Fixed versions

  • linux linux kernel: upgrade to 6.1.154 or later (affected from 6.0)
  • linux linux kernel: upgrade to 6.6.108 or later (affected from 6.2)
  • linux linux kernel: upgrade to 6.12.49 or later (affected from 6.7)
  • linux linux kernel: upgrade to 6.16.9 or later (affected from 6.13)

Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.

Vendor advisories and patches

Detection Generic guidance

    Response checklist Generic guidance

    1. Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
    2. Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
    3. Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
    4. Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.

    Sources