CVE-2025-2594: CVE-2025-2594: The User Registration & Membership WordPress plugin before 4.1.3 does not properly validat…
wpeverest · user registration \& membership · NVD published 2025-04-22 · posted 2025-05-25 · last modified 2026-06-17
What it is
The User Registration & Membership WordPress plugin before 4.1.3 does not properly validate data in an AJAX action when the Membership Addon is enabled, allowing attackers to authenticate as any user, including administrators, by simply using the target account's user ID.
| Weakness | Not specified |
|---|---|
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H (source: 134c704f-9b21-4f2e-91b3-4a467353bcc0) |
| ATT&CK tactics | n/a |
Exploitation evidence
First exploit evidence seen: 2025-05-25 (earliest date across the sources below).
Exploited in the wild
No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).
Public exploit code
Exploit-DB
- EDB-52302: WordPress User Registration & Membership Plugin 4.1.2 - Authentication Bypass (2025-05-25)
GitHub proof-of-concept repositories below quality bar
1 public repositories from 1 accounts, first seen 2025-04-22.
Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.
Sources: Exploit-DB (OffSec) · nomi-sec/PoC-in-GitHub.
No ATT&CK techniques could be mapped or inferred for this CVE yet.
How to fix it
Fixed versions
- wpeverest user registration \& membership: upgrade to 4.1.3 or later
- wpeverest user registration \& membership: upgrade to 5.1.3 or later
Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.
Vendor advisories and patches
No vendor-tagged reference yet; see the full reference list.
Detection Generic guidance
Response checklist Generic guidance
- Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
- Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
- Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
- Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.
Sources
- NVD: CVE-2025-2594
- CVE.org record
- FIRST EPSS (2026-10-24)
- https://wpscan.com/vulnerability/1c1be47a-d5c0-4ac1-b9fd-475b382a7d8f/ (Exploit, Third Party Advisory)