CRITICAL · CVSS 4.0 9.3Exploit-DBEPSS 1.81% (p79)Threat level 54
CVE-2024-51550: CVE-2024-51550: Data Validation / Data Sanitization vulnerabilities in Linux allows unvalidated and unsan…
abb · aspect-ent-12 firmware · NVD published 2024-12-05 · posted 2025-04-15 · last modified 2026-06-17
What it is
Data Validation / Data Sanitization vulnerabilities in Linux allows unvalidated and unsanitized data to be injected in an Aspect device. Affected products: ABB ASPECT - Enterprise v3.08.02; NEXUS Series v3.08.02; MATRIX Series v3.08.02
| Weakness | CWE-1287 |
|---|---|
| CVSS vector | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X (source: [email protected]) |
| ATT&CK tactics | n/a |
Exploitation evidence
First exploit evidence seen: 2025-04-15 (earliest date across the sources below).
Exploited in the wild
No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).
Public exploit code
Exploit-DB
- EDB-52217: ABB Cylon Aspect 3.08.02 (bbmdUpdate.php) - Remote Code Execution (2025-04-15)
Sources: Exploit-DB (OffSec).
No ATT&CK techniques could be mapped or inferred for this CVE yet.
How to fix it
Fixed versions
- abb aspect-ent-12 firmware: upgrade to 3.08.03 or later
- abb aspect-ent-2 firmware: upgrade to 3.08.03 or later
- abb aspect-ent-256 firmware: upgrade to 3.08.03 or later
- abb aspect-ent-96 firmware: upgrade to 3.08.03 or later
- abb nexus-2128 firmware: upgrade to 3.08.03 or later
- abb nexus-2128-a firmware: upgrade to 3.08.03 or later
- abb nexus-2128-f firmware: upgrade to 3.08.03 or later
- abb nexus-2128-g firmware: upgrade to 3.08.03 or later
- abb nexus-264 firmware: upgrade to 3.08.03 or later
- abb nexus-264-a firmware: upgrade to 3.08.03 or later
- abb nexus-264-f firmware: upgrade to 3.08.03 or later
- abb nexus-264-g firmware: upgrade to 3.08.03 or later
- abb nexus-3-2128 firmware: upgrade to 3.08.03 or later
- abb nexus-3-264 firmware: upgrade to 3.08.03 or later
- abb matrix-11 firmware: upgrade to 3.08.03 or later
- abb matrix-216 firmware: upgrade to 3.08.03 or later
- abb matrix-232 firmware: upgrade to 3.08.03 or later
- abb matrix-264 firmware: upgrade to 3.08.03 or later
- abb matrix-296 firmware: upgrade to 3.08.03 or later
Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.
Vendor advisories and patches
- https://search.abb.com/library/Download.aspx?DocumentID=9AKK108469A7497&LanguageCode=en&DocumentPartId=&Action=Launch (Vendor Advisory)
Detection Generic guidance
Response checklist Generic guidance
- Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
- Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
- Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
- Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.