CVE-2024-50562: CVE-2024-50562: An Insufficient Session Expiration vulnerability [CWE-613] in FortiOS SSL-VPN version 7.6.…
fortinet · fortisase · NVD published 2025-06-10 · posted 2025-06-20 · last modified 2026-06-17
What it is
An Insufficient Session Expiration vulnerability [CWE-613] in FortiOS SSL-VPN version 7.6.0, version 7.4.6 and below, version 7.2.10 and below, 7.0 all versions, 6.4 all versions may allow an attacker in possession of a cookie used to log in the SSL-VPN portal to log in again, although the session has expired or was logged out.
| Weakness | CWE-613 |
|---|---|
| CVSS vector | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N (source: [email protected]) |
| ATT&CK tactics | n/a |
Exploitation evidence
First exploit evidence seen: 2025-06-20 (earliest date across the sources below).
Exploited in the wild
No source on this site lists in-the-wild exploitation yet (CISA KEV, VulnCheck KEV).
Public exploit code
Exploit-DB
- EDB-52336: FortiOS SSL-VPN 7.4.4 - Insufficient Session Expiration & Cookie Reuse (2025-06-20)
GitHub proof-of-concept repositories below quality bar
1 public repositories from 1 accounts, first seen 2025-06-20.
Verify before running: public PoCs can be malicious. Read the code and only run it in an isolated lab. A PoC means exploit code is public, not that this CVE is exploited in the wild.
Sources: Exploit-DB (OffSec) · nomi-sec/PoC-in-GitHub.
No ATT&CK techniques could be mapped or inferred for this CVE yet.
How to fix it
Fixed versions
- fortinet fortios: upgrade to 7.2.11 or later (affected from 6.4.0)
- fortinet fortios: upgrade to 7.4.8 or later (affected from 7.4.0)
Derived from the NVD CPE configuration (versionEndExcluding / versionEndIncluding). Always confirm with the vendor advisory.
Vendor advisories and patches
- https://fortiguard.fortinet.com/psirt/FG-IR-24-339 (Vendor Advisory)
Detection Generic guidance
Response checklist Generic guidance
- Inventory: find every instance of the affected product and version (include internet-facing and forgotten ones).
- Patch or mitigate per the vendor advisory; if you cannot patch, remove internet exposure or apply the vendor workaround.
- Assume compromise if the system was exposed before patching: hunt for the indicators in the advisory and review logs back to the disclosure date.
- Rotate credentials and secrets stored on or used by the affected system if compromise cannot be ruled out.