How to fix CVE-2026-105133: AhsayCBS (exploited in the wild)
CVE-2026-105133 affects AhsayCBS; exploited in the wild. What it is, who is affected, and the steps to fix and verify it.
What it is
A vulnerability was detected in Ahsay AhsayCBS up to 10.3.2. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 10.3.4 is able to mitigate this issue. It is recommended to upgrade the affected component.
- Severity: MEDIUM (CVSS 4.0 5.5, vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P). - Weakness: CWE-287.
- NVD published 2026-10-04, status Analyzed.
Who's affected
Anyone running AhsayCBS in the version ranges below. Internet-facing instances are the priority.
- ahsay cloud backup suite: up to (not including) 10.3.4.
Version ranges come from the NVD CPE configuration. Confirm against the vendor advisory before you rely on them.
Exploitation status
- Exploited in the wild: added to the CISA Known Exploited Vulnerabilities catalog on 2026-10-14; federal remediation due date 2026-10-17.
Risk
- EPSS (probability of exploitation activity in the next 30 days): 5.79%, higher than 93% of all scored CVEs (as of 2026-10-24).
- CVERadar threat level: 44/100 (see methodology).
- Likely ATT&CK techniques: T1190 Exploit Public-Facing Application (inferred); T1078 Valid Accounts (inferred).
Remediation steps
- Find every instance. List where AhsayCBS runs, including test, DR and forgotten internet-facing systems, and record the installed version.
- Upgrade to a fixed release. ahsay cloud backup suite: 10.3.4 or later. Get the build from the vendor advisory.
- If you can't patch today, follow CISA's required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
- Verify the fix. Re-run the version check on every instance and confirm it reports the fixed build (10.3.4 or later). Re-scan from outside if the service is exposed.
- Hunt for signs of earlier compromise. If the system was exposed before you patched, assume it may have been hit and check the items below.
- Rotate credentials stored on or used by the affected system if you cannot rule out compromise, and keep the logs you reviewed.
Detection hints
- T1190 Exploit Public-Facing Application: Review WAF, reverse-proxy and application logs for unusual requests to AhsayCBS (odd paths, oversized or encoded payloads, bursts of errors), going back to at least 2026-10-04.
- T1078 Valid Accounts: Check for logins from new sources or accounts you did not create.
Detection commands are generic starting points, not CVE-specific signatures. Use the indicators from the vendor advisory when it publishes them.
Sources
- NVD: CVE-2026-105133 nvd.nist.gov/vuln/detail/CVE-2026-105133
- CVE.org record www.cve.org/CVERecord?id=CVE-2026-105133
- Vendor link from CISA KEV www.ahsay.com/en/company/announcements/patch-cve-105133-105134-update
- Release Notes www.ahsay.com/en/support/help-centre/release-notes/cbs/v10.3.4
- CISA KEV catalog www.cisa.gov/known-exploited-vulnerabilities-catalog
- FIRST EPSS (2026-10-24) api.first.org/data/v1/epss?cve=CVE-2026-105133
Track every exploited CVE
Full record for CVE-2026-105133, with the ATT&CK chain and every source. Browse what attackers are using right now, with fixes you can act on.