CVERadar

How to fix CVE-2023-22894: Strapi (exploited in the wild)

FIX GUIDE · EXPLOITED IN THE WILDCVE-2023-22894StrapiMEDIUMCVSS 4.9cveradar.org

CVE-2023-22894 affects Strapi; exploited in the wild. What it is, who is affected, and the steps to fix and verify it.

What it is

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.

  • Severity: MEDIUM (CVSS 3.1 4.9, vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N).
  • Weakness: CWE-312.
  • NVD published 2023-04-19, status Analyzed.

Who's affected

Anyone running Strapi in the version ranges below. Internet-facing instances are the priority.

  • strapi strapi: from 3.2.1 up to (not including) 4.8.0.

Version ranges come from the NVD CPE configuration. Confirm against the vendor advisory before you rely on them.

Exploitation status

  • Exploited in the wild: added to the CISA Known Exploited Vulnerabilities catalog on 2026-10-08; federal remediation due date 2026-10-11.
  • Public proof-of-concept code: 2 GitHub repositories from 2 accounts, the first on 2023-04-24.
Verify before running: public exploit and proof-of-concept code can be fake or carry malware. Only run it in an isolated lab, after reading the code.

Risk

  • EPSS (probability of exploitation activity in the next 30 days): 3.61%, higher than 89% of all scored CVEs (as of 2026-10-24).
  • CVERadar threat level: 41/100 (see methodology).

Remediation steps

  1. Find every instance. List where Strapi runs, including test, DR and forgotten internet-facing systems, and record the installed version.
  2. Upgrade to a fixed release. strapi strapi: 4.8.0 or later. Get the build from the vendor advisory.
  3. If you can't patch today, follow CISA's required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
  4. Verify the fix. Re-run the version check on every instance and confirm it reports the fixed build (4.8.0 or later). Re-scan from outside if the service is exposed.
  5. Hunt for signs of earlier compromise. If the system was exposed before you patched, assume it may have been hit and check the items below.
  6. Rotate credentials stored on or used by the affected system if you cannot rule out compromise, and keep the logs you reviewed.

Detection hints

  • Check the vendor advisory for indicators of compromise and review the affected system's logs back to the disclosure date.

Detection commands are generic starting points, not CVE-specific signatures. Use the indicators from the vendor advisory when it publishes them.

Sources

← Back to blog
Keep reading

Related articles

Track every exploited CVE

Full record for CVE-2023-22894, with the ATT&CK chain and every source. Browse what attackers are using right now, with fixes you can act on.

Exploited in the wildHow we score